Основное меню программы

Основое меню находится в верхней части главного окна программы и содержит в себе вызовы действий, связанных с проектом в целом. Меню разделено на 4 части: Проект, Данные, Сервис и Помощь. В зависимости от режима, в котором находится программа к основному меню могут быть добавлены дополнительные или убраны некоторые пункты.

Меню Проект

image2

Это меню позволяет создать новый проект, открыть существующий, сохранить изменения текущего проекта, а также сделать копию открытого проекта. Подробное описание этих функций дано в главе 1 данного руководства.

Меню Данные

image3

Меню Данные предназначено для выполнения действий над отдельными элементами проекта. Через это меню можно добавить в проект файл с текстом программы, подготовленный в каком-либо другом текстовом редакторе, а не штатными средствами программы, также можно добавить в проект электронную таблицу, подготовленную другим модулем системы или на другом персональном компьютере. Кроме этого существует возможность переименовать элемент проекта. Это бывает необходимо, если во время создания какого-либо элемента не изменить имя, предлагаемое по умолчанию, а также после импорта.

Меню Сервис

image4

Меню Сервис предназначено для выполнения дополнительных функция над элементами проекта. Это импорт БД в формате dBase III+,Paradox 3.5=4.5, экспорт БД в формат dBase III+ или в текстовый с разделителями. Также в этом меню находится вызов процедуры проверки целостности данных, а также электронных таблиц в формат Microsoft Excel (Microsoft Excel должен быть установлен на компьютер).

Импорт данных

Диалоговое окно, используемое для импорта представлено на рис 2.1. В списке Источник данных показываются файлы, располженные на Вашем жестком диске. Если исходные данные были подговлены в среде MS=DOS, то необходимо установить перелючатель "Перекодировка DOS=>Windows", если же данные были подговлены в операционной системе Windows (например экспорт из Microsoft Excel), то необходимости в перекодировке нет, и переключатель нужно сбросить.

image5

Рис 2.1

При импорте новый файлы получают автоматическое имя "Данные 1", "Данные 2", и т.д. Для переименования можно воспользоваться соответствующим пунктом меню Данные.

При выборе закладки "Импорт-эксперт" появляется возможность произвести сопоставление данных с жесткого диска с теми данными, которые уже существуют в Вашей БД, т.е. в существующей БД будут изменены только те записи, значения ключевых полей в которых совпадают со значениями ключевых полей внешней БД.

Экспорт данных

Для экспорта необходимо выбрать нужный элемент проекта и выполнить пункт меню "Экспорт". В появившемся диалоговом окне необходимо указать имя файла, в который Вы хотите сохранить результат. Кроме экспорта БД программа может осуществлять эспорт электронных таблиц в систему Microsoft Excel.

Примечание

Важно: Для экспорта необходимо, чтобы программа Microsoft Excel была установлена на Вашем компьютере.

Примечание

Важно: При экспорте электронных таблиц большого объема возможно некоторое "зависание" компьютера. Ничего страшного в этом нет – просто идет преобразование данных из формата электронной таблицы NetCalc в формат Microsoft Excel. По окончании преобразований компьютер снова "оживет".

Проверка целостности

Одном из важных пунктов меню Сервис является подпункт "Проверка целостности". Необходимость в такой проверке может возникнуть при некорректном выходе из программы, при сбое питания. При выборе этого пункта меню на экране появляется диалоговое окно, представленное на рис 2.2

image6

Рис 2.2

В левой части этого окна находится список БД проекта. В правой части окна находятся закладки Общие, Поля, Блоки и Проверка. Первые три закладки представляют служебную информацию о БД, которая может быть интересна лишь разработчикам. Закладка Проверка собственно и предназначена для проверки целостности связей между базами данных. При нажатии кнопки "Проверить" программа произведет правильность ссылок на выбранную БД, также будут произведена проверка на существование всех ссылок из выбранной БД, при явных ошибках будет произведено их исправление. Во время проверки в области сообщений будет отображаться ход проверки, также в нижней части окна будет показано соотнеошение выполненной части и оставшейся.

Оптимизация

Для вызова этой функции необходимо выделить в главном окне проекта нужную БД и нажать правую кнопку мыши. В появившемся меню выбрать пункт "Оптимизация". Эта операция бывает необходима после большого количества операций удаления записей, можно рассматривать её как средство упаковки БД. Внешний вид окна оптимизации представлен на рис 2.3.

image7

Рис 2.3

В левой части окна отображается служебная информация о БД. В правой части окна отображается статистика по количеству записей в цепочках подчиненных файлов, а также присутствуют настройки для оптимизации. В большинстве случаев нет необходимости менять настройки по умолчанию. В этом случае программа удалить из файлов БД всю неиспользуемую информацию – за счет этого уменьшается размер файлов БД, соответственно увеличивается свободное место на диске.

Необходимость использовать переключатель "Оптимизировать блоки" может возникнуть лишь в одном случае: если файл, который Вы оптимизируете является подчиненным и предназначен для хранение информации, доступ к которой осуществляется через поле, тип которого "Жесткая ссылка на запись" (более подробно об этом см. Глава 3, "Создание файлов данных". Если же Вы решили использовать это переключатель, то после обычной оптимизации перед Вами появится еще одно диалоговое окно (рис 2.4)

image8

Рис 2.4

Программа подсчитает срдневзвешенное значение длин цепочек и предложит изменить размер блока по умолчанию (стандартный размер блока равен 5 записей). Вы можете не согласиться с тем значением, которое предложила программа и подставить своё. Однако нужно помнить, что для главных файлов размер блока лучше оставить по умолчанию – 5 записей, а что касается подчиненных – если Вы выбрали размер блока, слишком маленьким и при этом новый размер файла у Вас получился наименьшим – это может привести к замедлению работы системы, особенно на операция добавления/удаления записей, поэтому настоятельно не рекомендуем изменять значения по умолчанию, если Вы не уверены окончательно в своих действиях.

Меню Помощь

Через это меню можно вызвать помощь по работе с программой, в частности с главным окном проекта в целом, и с электронной таблицей отдельно.